読者です 読者をやめる 読者になる 読者になる

Make Healthy Life

最近はSQLばっかり書いてるWebエンジニアの日記です。

bootstrap 3 をrails 4で使う

なぜか最新情報があまり見当たらなかったのでメモ。
railsでbootstrapを使うなら、twitter-bootstrap-railsというGemを使え!みたいな記事が多い。
でもtwitter bootstrap 3をrails 4 で使おうとすると、去年まではtwitter-bootstrap-railsが対応してなかったので、bootstrapをvender配下に設置したり、違うGemを使ったりしないといけなかったらしい。
対応してなかったから自分用に作った、なんて強者もいた。
jasontorres/bootstrap-on-rails · GitHub
(でもこのGemはなんかうまく動かせなかった。。。)


でもtwitter-bootstrap-railsの最新ソースを使うだけで出来たよ〜という報告です。
Gemfileに最新ソースを使うことを宣言してやればいい。

gem "twitter-bootstrap-rails", :git => 'git://github.com/seyhunak/twitter-bootstrap-rails.git'